Sharepoint slave contacts not being removed

You want to synchronize your Mobile Phone with other Microsoft Outlook folders than default-folders? So you can have a look at OLMixedFolders.
Post Reply
Ryan
Posts: 7
Joined: Tue Apr 09, 2013 1:32 am

Sharepoint slave contacts not being removed

Post by Ryan »

I have a Sharepoint 365 contact list that is connected to Outlook (this is the master folder).
I have configured OLMixedFolders 1.49.21 on this master folder to
- Synchronize this folder
- Create Subfolder
- all other options are default

case 1/
After waiting for synchronization, the slave folder has the same number of contacts as the master folder.
If I delete 2 contacts from the master folder in Outlook, the slave folder is updated with minus 2 contacts.
I confirm in Sharepoint that there are 2 less contacts than before.
So far so good, but this only works from my own computer.

case 2/
I log into a different computer, with a different email address.
I connect the Sharepoint 365 contact list to this Outlook, same way as above.
If I delete 2 contacts from this Outlook, I can confirm in Sharepoint that there are 2 less contacts.

Going back to my own computer, my master folder also shows 2 less contacts.
But the slave folder will not update, and it is now out of sync with 2 more contacts than the master folder.
Waiting over the weekend to give it time to sync has not resolved the issue.

Some numbers might explain more clearly:
- before deleting, there are 4500 contacts in Sharepoint
- after deleting from 2nd computer, Sharepoint shows 4498 contacts
- on my computer, master folder shows 4498 contacts
- on my computer, slave folder shows 4500 contacts
User avatar
Sven
Site Admin
Posts: 1516
Joined: Sun Jan 06, 2008 9:54 pm
Contact:

Re: Sharepoint slave contacts not being removed

Post by Sven »

Hello,

Please could you try the newest version, you can download it from here http://www.somebytes.de/downloads/OLMixedFolders.zip

One Thing could be that the Clients Folder was not updated. Because SharePoint is not updating folders in Outlook by itselfes you have to use the "Send & recive" function from Outlook. After that OLMixedFolders can work with the changes.

BR
SIL
Ryan
Posts: 7
Joined: Tue Apr 09, 2013 1:32 am

Re: Sharepoint slave contacts not being removed

Post by Ryan »

Hi,

I tried version 1.49.31 as you suggested and here's what I found.
In trying to reproduce the problem, I created 2 test contacts in Outlook, under my own local contacts.
Then I dragged these 2 test contacts to the Sharepoint connection (master folder) in Outlook.
The Olmixedfolders icon started spinning, and after syncing, the slave folder had 2 additional contacts.
I deleted these 2 test contacts from the master folder, the icon started spinning again, and the 2 contacts
were removed from the slave folder. Everything seems correct so far.

Drag the same 2 test contacts into the master folder again - this time the icon does not spin,
and the slave folder does not update (I now have 2 more contacts in master than in slave).
In Outlook, clicking Update Folder, or Send/Receive all Folders does not fix the problem - olmixedfolders
does not recognize that the master folder has changed.
Delete the 2 test contacts from the master folder - icon starts spinning.

I waited for the icon to stop spinning, then repeated this experiment 2 more times with the same result:
olmixedfolders does not recognize that 2 contacts were added to the master folder,
but it does recognize that 2 contacts were deleted from the master folder.

Please help.

Thanks,
Ryan
User avatar
Sven
Site Admin
Posts: 1516
Joined: Sun Jan 06, 2008 9:54 pm
Contact:

Re: Sharepoint slave contacts not being removed

Post by Sven »

OK, but what is happend if you dont copy it from the linked Folder because OLMixedFolder can notice that to prevent problems with items it has copied by itselfe. What if you copy the items from onother folder, or create it manually?
Ryan
Posts: 7
Joined: Tue Apr 09, 2013 1:32 am

Re: Sharepoint slave contacts not being removed

Post by Ryan »

I created the contacts manually in the master folder, and OLMixedFolders seems to recognize the master folder has changed.
I also created a new folder, and dragged the contact from this new folder to the master folder
- sometimes the slave is updated, sometimes not.

I think I may have found the cause - it has to do with reusing the same contact for testing.

So dragging the contact to the master folder the first time will usually work - the slave is updated.
If you delete the contact from the master - the slave is also updated.
Then if you drag the same contact into the master folder again, OLMixedFolders might fail to recognize the master has changed.
This seems like a caching problem with OLMixedFolders - Sharepoint is able to correctly recognize the contact is added/deleted.
The contact's name seems to make a difference.

This is an issue for my client because they sometimes (by accident) have duplicate contacts, or contacts that are very close,
but differ by one or two fields. For example, they might have two contacts with the same name, but different job title.

Thanks,
Ryan
User avatar
Sven
Site Admin
Posts: 1516
Joined: Sun Jan 06, 2008 9:54 pm
Contact:

Re: Sharepoint slave contacts not being removed

Post by Sven »

OK, that's the copy&paste issue. So I have to say, please download again the newest version, because the mechanism which takes care of the copy&paste was broken. I have fiexed in the new version.
http://www.somebytes.de/downloads/OLMixedFolders.zip
It can be that the Client and master drag&drop is still not working, but should't be a Problem, because OLMIxedFolders will do it.
Ryan
Posts: 7
Joined: Tue Apr 09, 2013 1:32 am

Re: Sharepoint slave contacts not being removed

Post by Ryan »

Hi,

I downloaded and installed version 1.49.35.

The sharepoint master folder currently has 4530 contacts.
I dragged 3 test contacts from My Contacts/test folder/ to the master folder.
The OLMixedFolders icon animated for about 90s, as it tried to sync master folder to slave folder.
The master folder now has 4533 contacts, and the slave folder also has 4533 contacts.

I deleted the 3 test contacts from master folder.
OLMixedFolders icon animated for about 90s.
Master and slave folders both have 4530 contacts now.

I dragged 1 of the test contacts (one of the same 3 above) to the master folder.
OLMixedFolders icon animated for 0.5s then stopped.
The master folder now has 4531 contacts, but the slave folder has 4530.
So the problem still exists - OLMixedFolders does not upate the slave folder - even though the icon animated very briefly.

If I go to the master folder, right click properties, goto OLMixedFolders tab, and enable Reset, then click OK,
the icon animates for about 30 minutes. When it was done, the slave folder was updated - 4531 contacts.

Ryan
User avatar
Sven
Site Admin
Posts: 1516
Joined: Sun Jan 06, 2008 9:54 pm
Contact:

Re: Sharepoint slave contacts not being removed

Post by Sven »

Hello,

Ok, I will test it with am Installation like yours. What store is the target. Is it Outlook PST file or is it Exchange Mailbox.

BR
SIL
User avatar
Sven
Site Admin
Posts: 1516
Joined: Sun Jan 06, 2008 9:54 pm
Contact:

Re: Sharepoint slave contacts not being removed

Post by Sven »

Hello,

I have tested with an Exchange store and have found one bug. So it's now removed and you can load the newest Version from here: http://www.somebytes.de/downloads/OLMixedFolders.zip

BR
SIL
Ryan
Posts: 7
Joined: Tue Apr 09, 2013 1:32 am

Re: Sharepoint slave contacts not being removed

Post by Ryan »

Hi Sven,

I downloaded version 1.49.37 from the link you provided, and repeated the same tests that I did before.
It looks like the problem is now resolved, thank you.

Ryan
Post Reply