EEAttachments has stopped processing emails

The Exchange service EEAttachments can save your attachments or mails automatically to your file-system and process it by your own scripts.
Post Reply
justin.jones
Posts: 3
Joined: Mon Aug 11, 2014 11:04 pm

EEAttachments has stopped processing emails

Post by justin.jones » Wed Aug 13, 2014 10:30 am

Hi,

After getting everything set up again and seeing that emails were coming into my inbox, being processed by EEAttachments to extract the file and delete the email and then my own batch file processing this file I left for the evening happy that all was OK again. I had been monitoring the flow for the day and was very happy.

I have come in this morning and seen that my Inbox had around 80 emails signifying that the process had not run since around 1940 last night. On looking at the server I can see that the service was still in a started state and there were no errors in the log files; the application event viewer did not have any errors or stop events for EEAttService. I did notice that the clock on the server running the service was 5 minutes behind but resetting this did not trigger off any processes.

In the end I stopped and restarted the service and everything processed as expected.

Can you advise what may stop the serice from procesing new emails coming through please as I would not like this to be a reoccuring issue. I will send through the logs via email.

Regards,
Justin.

User avatar
Sven
Site Admin
Posts: 1461
Joined: Sun Jan 06, 2008 9:54 pm
Contact:

Re: EEAttachments has stopped processing emails

Post by Sven » Wed Aug 13, 2014 10:50 am

Hello,

It can be that you are loosing the SteamingNotification from Exchange, after that it will check all 30 Minutes by polling. I will make a new parameter, where you can change the force polling interval. Also I will check if there are possibility to catch that error in StreamingNotification.

imiservice
Posts: 3
Joined: Wed Jun 17, 2015 12:07 am

Re: EEAttachments has stopped processing emails

Post by imiservice » Wed Jun 17, 2015 3:57 pm

We are running EEATTACHMENTS for three mailboxes. We also have seen the function just drop off, services are running, logs show no break, yet mail stops flowing. Sometimes restarting the services will kick things off again, other times restarting services makes no change and mail will not flow til the box is restarted. We have more consistent success having broken up the three flows into one per machine. Yet the flow appears to die intermittently. Where do you adjust the force poll?

User avatar
Sven
Site Admin
Posts: 1461
Joined: Sun Jan 06, 2008 9:54 pm
Contact:

Re: EEAttachments has stopped processing emails

Post by Sven » Thu Jun 18, 2015 3:43 pm

At the current version it's included in the Job.settings.conf
You can find it, if you open C:\ProgramData\EEAttachments\ where you will see some ...Job.settings.conf files. These are the exporttask configurations. If you open these by texteditor you can change the parameter "ForcePollingIntervall" individually for each job.

imiservice
Posts: 3
Joined: Wed Jun 17, 2015 12:07 am

Re: EEAttachments has stopped processing emails

Post by imiservice » Mon Jun 22, 2015 10:56 pm

Thanks for the force polling information. We are using Office 365 - we did not experience EEAttachments not processing emails until we migrated. Without a pattern we can discern, the application will simply stop processing emails, restarting usually will fix this. Lowering the ForcePoll did not seem to impact the drop in processing.

We are now seeing the application crash, and these error messages:


E:2015-06-19T18:55:44 (EEAttachments.exe)=>() TraceFailed: The process cannot access the file 'C:\ProgramData\EEAttachments\EEAttachmentsTrace_ServiceConnection.log' because it is being used by another process.
E:2015-06-19T21:11:11 (EEAttachments.exe)=>(cpts) SubscriptionError Unable to retrieve events for this subscription. The subscription must be recreated.
I:2015-06-19T21:11:23 (EEAttachments.exe)=>(cpts) StreamingSubscriptions enabled

User avatar
Sven
Site Admin
Posts: 1461
Joined: Sun Jan 06, 2008 9:54 pm
Contact:

Re: EEAttachments has stopped processing emails

Post by Sven » Tue Jun 23, 2015 12:09 pm

OK, in this case it's better to untick the subscriptions at all.
If you open the configuration files from job, you can see a "<SubscriptionAllowed>true</SubscriptionAllowed>". Please change it to <SubscriptionAllowed>false</SubscriptionAllowed>

imiservice
Posts: 3
Joined: Wed Jun 17, 2015 12:07 am

Re: EEAttachments has stopped processing emails

Post by imiservice » Tue Jun 23, 2015 6:13 pm

Thanks very much for your assistance. Where is the subscription option? I don't see it in the job config?

User avatar
Sven
Site Admin
Posts: 1461
Joined: Sun Jan 06, 2008 9:54 pm
Contact:

Re: EEAttachments has stopped processing emails

Post by Sven » Wed Jun 24, 2015 12:03 pm

Have you found the job config files in C:\ProgramData\EEAttachments\ ?
You should find it in each of that config files.

But if you like, you can download the newest version from here: http://www.somebytes.de/downloads/EEAttachments.zip

I have changed it so, that by default the Subscription is off and it's possible now to change that setting from main config file or by each of the jobs.

Post Reply